AlbHost Service Status - Node/Hypervisor 28 – Server issue – Incident details

All systems operational

AlbHost Service Status

Node/Hypervisor 28 – Server issue

Resolved
Major outage
Started about 15 hours agoLasted about 3 hours

Affected

Other Notifications

Major outage from 1:45 PM to 4:50 PM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Investigating
    UTC
    Investigating

    Hello,

    We are currently investigating issues affecting Node/Hypervisor 28. Some virtual servers hosted on this node may experience degraded performance or temporary connectivity issues.

    Our technical team is working to identify and resolve the issue as quickly as possible. Further updates will be provided as more information becomes available.

    Thank you for your understanding and patience.

    AlbHost Team